Back to overview
Downtime
SSL failure
Oct 20 at 12:41am CEST
Affected services
Home Page
Resolved
Oct 20 at 07:43am CEST
We were able to identify the root cause and fix the issue. Steps will be taken to minimize such downtimes in the future.
Affected services
Home Page
Created
Oct 20 at 12:41am CEST
Auto-renewal of SSL failed owing to a mis-configuration
Affected services
Home Page